PCD Control Plane Maintenance

Scheduled for Sep 28, 20:30 PDT  -  Sep 29, 08:30 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 16, 2025 - 05:40 PDT

Scheduled

As part of the security activity, certain components of the control plane require volume encryption and service upgrades. During this process, it is anticipated that there will be little to no impact on PCD customers regarding the API services of PCD.
Posted Sep 16, 2025 - 05:40 PDT
This scheduled maintenance affects: Platform9 Cloud.